service_worker 0.2.4
service_worker: ^0.2.4 copied to clipboard

JavaScript bindings for the Service Worker API.

17
likes
70/ 130
pub points
82%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-14T06:22:24.464427] Starting...
Documenting service_worker...
Initialized dartdoc with 48 libraries in 33.9 seconds
Generating docs for library service_worker from package:service_worker/service_worker.dart...
Generating docs for library service_worker.window from package:service_worker/window.dart...
Generating docs for library service_worker from package:service_worker/worker.dart...
Documented 3 public libraries in 2.2 seconds

stderr:   warning: ambiguous reexport of service_worker_api.ExtendableEvent, canonicalization candidates: (service_worker, service_worker, service_worker.window) -> service_worker.window (confidence 0.01000)
    from service_worker_api.ExtendableEvent: (file:///tmp/pub-dartlang-dartdocWVMRKG/pkg/lib/src/service_worker_api.dart:603:7)
        service_worker: -0.7900 - is deprecated (-1.000), name is long (+0.01000), element location shares parts with name (+0.2000)
        service_worker: 0.2100 - name is long (+0.01000), element location shares parts with name (+0.2000)
        service_worker.window: 0.2200 - name is long (+0.02000), element location shares parts with name (+0.2000)
            Use {@canonicalFor service_worker_api.ExtendableEvent} in the desired library's documentation to resolve
            the ambiguity and/or override dartdoc's decision, or structure your package 
            so the reexport is less ambiguous.  The symbol will still be referenced in 
            all candidates -- this only controls the location where it will be written 
            and which library will be displayed in navigation for the relevant pages.
            The flag --ambiguous-reexport-scorer-min-confidence allows you to set the
            threshold at which this warning will appear.
  warning: ambiguous reexport of service_worker_api.NotificationEvent, canonicalization candidates: (service_worker, service_worker, service_worker.window) -> service_worker.window (confidence 0.01000)
    from service_worker_api.NotificationEvent: (file:///tmp/pub-dartlang-dartdocWVMRKG/pkg/lib/src/service_worker_api.dart:873:7)
        service_worker: -0.7900 - is deprecated (-1.000), name is long (+0.01000), element location shares parts with name (+0.2000)
        service_worker: 0.2100 - name is long (+0.01000), element location shares parts with name (+0.2000)
        service_worker.window: 0.2200 - name is long (+0.02000), element location shares parts with name (+0.2000)
  warning: ambiguous reexport of service_worker_api.ServiceWorkerRegistration, canonicalization candidates: (service_worker, service_worker, service_worker.window) -> service_worker.window (confidence 0.01000)
    from service_worker_api.ServiceWorkerRegistration: (file:///tmp/pub-dartlang-dartdocWVMRKG/pkg/lib/src/service_worker_api.dart:438:7)
        service_worker: -0.7900 - is deprecated (-1.000), name is long (+0.01000), element location shares parts with name (+0.2000)
[...]
    from service_worker.window.ShowNotificationOptions.vibrate: (file:///tmp/pub-dartlang-dartdocWVMRKG/pkg/lib/src/js_facade/service_worker_api.dart:562:26)
  error: failed to write file at: service_worker/service_worker-library.html
    for symbol service_worker: (file:///tmp/pub-dartlang-dartdocWVMRKG/pkg/lib/worker.dart:2:9)
    conflicting with file already generated by service_worker: (file:///tmp/pub-dartlang-dartdocWVMRKG/pkg/lib/service_worker.dart:4:9)
            Dartdoc generates a path and filename to write to for each symbol.
            service_worker conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: unresolved doc reference [300, 100, 400]
    from service_worker.Notification.vibrate: (file:///tmp/pub-dartlang-dartdocWVMRKG/pkg/lib/src/js_facade/service_worker_api.dart:478:26)
Found 12 warnings and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:241:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:service_worker/service_worker.dart that imports:
  • package:service_worker/src/service_worker_api.dart that imports:
  • package:service_worker/src/js_facade/service_worker_api.dart that imports:
  • package:service_worker/src/js_facade/promise.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js^0.6.10.6.30.6.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

17
likes
70
pub points
82%
popularity

JavaScript bindings for the Service Worker API.

Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

js

More

Packages that depend on service_worker