serdes_json_generator 0.4.3 icon indicating copy to clipboard operation
serdes_json_generator: ^0.4.3 copied to clipboard

code generator for serdes_json

0
likes
70/ 140
pub points
28%
popularity

We analyzed this package 3 days ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 98 API elements (5.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:serdes_json_generator/builder.dart that imports:
  • package:serdes_json_generator/generator.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform iOS

Because:

  • package:serdes_json_generator/builder.dart that imports:
  • package:serdes_json_generator/generator.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Windows

Because:

  • package:serdes_json_generator/builder.dart that imports:
  • package:serdes_json_generator/generator.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Linux

Because:

  • package:serdes_json_generator/builder.dart that imports:
  • package:serdes_json_generator/generator.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform macOS

Because:

  • package:serdes_json_generator/builder.dart that imports:
  • package:serdes_json_generator/generator.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Web

Because:

  • package:serdes_json_generator/builder.dart that imports:
  • package:serdes_json_generator/generator.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Unused import: 'package:analyzer/dart/element/type.dart'.

lib/generator.dart:3:8

  ╷
3 │ import 'package:analyzer/dart/element/type.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/generator.dart

lib/generator.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^3.2.03.4.15.2.0
build^2.0.02.3.12.3.1
collection^1.15.01.16.01.17.0
equatable^2.0.02.0.52.0.5
recase^4.0.04.1.04.1.0
serdes_json^0.4.00.4.00.4.0
source_gen^1.0.01.2.21.2.6
source_helper^1.3.11.3.21.3.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-38.0.050.0.0
args-2.3.12.3.1
async-2.10.02.10.0
characters-1.2.11.2.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-2.2.32.2.4
file-6.1.46.1.4
flutter-0.0.00.0.0
glob-2.1.12.1.1
logging-1.1.01.1.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
package_config-2.1.02.1.0
path-1.8.21.8.2
pub_semver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^3.2.0 on analyzer does not support the stable version 4.0.0.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.