serde_generator 1.1.2

Dart native

The generator for the dart_serde package, is responsible for generate the code that will serialize or deserialize an class

0
likes
70 / 110
pub points
2 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 10 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:serde_generator/serde_generator.dart that imports:
  • package:serde_generator/src/serde_generator.dart that imports:
  • package:analyzer/dart/constant/value.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/generated/type_system.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/util/comment.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/helpers/mixins/string_modifiers.dart:6:36

  ╷
6 │       return name.replaceAllMapped(new RegExp(r'[A-Z]'), (Match match) => '_' + match.group(0).toLowerCase());
  │                                    ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/helpers/mixins/string_modifiers.dart

lib/builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.38.20.38.50.40.3
build>=0.12.0 <2.0.01.5.01.5.0
serde^1.0.61.0.61.0.6
source_gen^0.9.00.9.4+60.9.7+1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.31.3.7
front_end-0.1.270.1.29
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
js-0.6.20.6.2
kernel-0.3.270.3.29
logging-0.11.40.11.4
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.38.2` on analyzer does not support the latest published version `0.40.3`

pubspec.yaml:11:13

   ╷
11 │   analyzer: ^0.38.2
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
2%
popularity

The generator for the dart_serde package, is responsible for generate the code that will serialize or deserialize an class

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

eduardoaikin@gmail.com

License

unknown (LICENSE)

Dependencies

analyzer, build, serde, source_gen

More

Packages that depend on serde_generator