sentry_client 4.2.1

pub Build Status codecov documentation

The Dart library for sending data to the Sentry server. #

Usage in browser: #

var client = new SentryClientBrowser(
  SentryDsn.fromString('https://123456789abcdef123456789abcdef12@sentry.local/1')
);

client.write(new SentryPacket());

Usage on server: #

var client = new SentryClientServer(
  SentryDsn.fromString('https://123456789abcdef123456789abcdef12@sentry.local/1')
);

client.write(new SentryPacket());

Changelog #

4.2.1 #

  • Fix the uuid dependence to ^1.0.0 - compatible with Dart 2

4.2.0 #

4.1.0 #

  • Update the linter rules & remove nulls from the request

4.0.4 #

  • Prepare for dart 2.0
  • Remove 1.21.1 checks
  • Change SentrySDK (lib/api_data/sentry_sdk.dart) for new versions!

4.0.3 #

  • Correct the build shield

4.0.2 #

  • The integration with travis-ci.com and codecov.io

4.0.1 #

  • The authors format was fixed

4.0.0 #

  • The first open-source version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sentry_client: ^4.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sentry_client/sentry_client.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
74
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:sentry_client/sentry_client.dart.

Health suggestions

Fix lib/api_data/sentry_packet.dart. (-8.63 points)

Analysis of lib/api_data/sentry_packet.dart reported 18 hints, including:

line 11 col 1: Prefer using /// for doc comments.

line 18 col 3: Prefer using /// for doc comments.

line 25 col 3: Prefer using /// for doc comments.

line 34 col 3: Prefer using /// for doc comments.

line 40 col 3: Prefer using /// for doc comments.

Fix lib/api_data/sentry_stacktrace_frame.dart. (-6.31 points)

Analysis of lib/api_data/sentry_stacktrace_frame.dart reported 13 hints, including:

line 4 col 3: Prefer using /// for doc comments.

line 9 col 3: Prefer using /// for doc comments.

line 14 col 3: Prefer using /// for doc comments.

line 19 col 3: Prefer using /// for doc comments.

line 24 col 3: Prefer using /// for doc comments.

Fix lib/api_data/sentry_request.dart. (-3.93 points)

Analysis of lib/api_data/sentry_request.dart reported 8 hints, including:

line 3 col 1: Prefer using /// for doc comments.

line 9 col 3: Prefer using /// for doc comments.

line 14 col 3: Prefer using /// for doc comments.

line 19 col 3: Prefer using /// for doc comments.

line 25 col 3: Prefer using /// for doc comments.

Fix additional 11 files with analysis or formatting issues. (-9.92 points)

Additional issues in the following files:

  • lib/api_data/sentry_exception.dart (7 hints)
  • lib/api_data/sentry_user.dart (5 hints)
  • lib/api_data/sentry_stacktrace.dart (3 hints)
  • lib/http_adaptors/http_adapter_browser.dart (2 hints)
  • lib/sentry_client_browser.dart (1 hint)
  • lib/sentry_client_server.dart (1 hint)
  • lib/sentry_dsn.dart (1 hint)
  • lib/api_data/sentry_sdk.dart (Run dartfmt to format lib/api_data/sentry_sdk.dart.)
  • lib/http_adaptors/http_adapter.dart (Run dartfmt to format lib/http_adaptors/http_adapter.dart.)
  • lib/http_adaptors/http_adapter_server.dart (Run dartfmt to format lib/http_adaptors/http_adapter_server.dart.)
  • lib/sentry_client.dart (Run dartfmt to format lib/sentry_client.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (uuid).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and sentry_client.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-5 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-4.66 points)

The package was last published 54 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.36.0 <3.0.0
uuid ^1.0.0 1.0.3 2.0.2
Transitive dependencies
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.2
typed_data 1.1.6
Dev dependencies
build_runner >=0.9.1 <2.0.0
build_test >=0.10.2 <2.0.0
build_web_compilers >=0.4.0 <2.0.0
mockito ^3.0.0
quiver ^2.0.0
test ^1.3.0