sembast 1.9.0
sembast: ^1.9.0 copied to clipboard

outdatedDart 2 incompatible

Simple embedded file system database

1.9.0 #

  • New transaction API
  • dart2 only

1.8.0 #

  • fix flutter cast issue
  • fix limit/offset implementation
  • Update synchronized dependency
  • make all constants lowercase

1.7.0 #

  • mode databaseModeNeverFails is the new default
  • API cleanup and add deprecations

1.6.1 #

  • Add implicit-cast: false support

1.6.0 #

1.5.0 #

  • Update synchronized dependency
  • Add DatabaseMode.NEVER_FAILS that will ignore the file once a corrupted record is encountered

1.3.9 #

  • Add web example to test ddc support
  • Fix transaction

1.3.7 #

  • Strong mode support
  • support for setting record field directly
  • fix support for dart 1.24

1.3.1 #

  • Add support for import/export

1.2.2 #

  • Add for support for isNull and notNull filter
  • Add for support for sorting null last
  • Travis test integration

1.0.0 #

  • Initial revision