select_dialog 2.0.0
select_dialog: ^2.0.0 copied to clipboard

Package designed to select an item from a list, with the option to filter and even search the items online.

36
likes
120 / 130
pub points
92 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 116 out of 185 API elements (62.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: 'searchHint' is deprecated and shouldn't be used. Use 'hintText' property from searchBoxDecoration.

lib/select_dialog.dart:202:83

    ╷
202 │                 decoration: widget.searchBoxDecoration?.copyWith(hintText: widget.searchHint ?? widget.searchBoxDecoration!.hintText) ?? InputDecoration(hintText: widget.searchHint ?? "Find", contentPadding: const EdgeInsets.all(2.0)),
    │                                                                                   ^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/select_dialog.dart

INFO: 'searchHint' is deprecated and shouldn't be used. Use 'hintText' property from searchBoxDecoration.

lib/select_dialog.dart:202:171

    ╷
202 │                 decoration: widget.searchBoxDecoration?.copyWith(hintText: widget.searchHint ?? widget.searchBoxDecoration!.hintText) ?? InputDecoration(hintText: widget.searchHint ?? "Find", contentPadding: const EdgeInsets.all(2.0)),
    │                                                                                                                                                                           ^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/select_dialog.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

36
likes
120
pub points
92%
popularity

Package designed to select an item from a list, with the option to filter and even search the items online.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

davidsdearaujo@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on select_dialog