select_days_week 0.1.1
select_days_week: ^0.1.1 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A Widget to select days of the week, with the possibility of simple and multiple selection, filtering and validation

2
likes
90 / 110
pub points
59 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 27 API elements (3.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/select_days_week_widget.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_mobx^1.1.01.1.0+21.1.0+2
intl^0.16.10.16.10.17.0
mobx^1.1.11.2.1+41.2.1+4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`, that was published 25 days ago.

When intl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

2
likes
90
pub points
59%
popularity

A Widget to select days of the week, with the possibility of simple and multiple selection, filtering and validation

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

renidelonzek@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, flutter_mobx, intl, mobx

More

Packages that depend on select_days_week