search_choices 2.2.7 copy "search_choices: ^2.2.7" to clipboard
search_choices: ^2.2.7 copied to clipboard

Highly customizable Widget to search through a single or multiple choices list in a dialog box or a menu. Supports pagination, future/API/webservice searches with sort and filter.

512
likes
130/ 140
pub points
96%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

125 out of 129 API elements (96.9 %) have documentation comments.

Some symbols that are missing documentation: search_choices.SearchChoices.checkPreconditions, search_choices.SearchChoices.isEnabled, search_choices.kAlignedButtonPadding, search_choices.kUnalignedButtonPadding.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Use 'isEmpty' instead of 'length' to test whether the collection is empty.

lib/src/dropdown/dropdown_dialog.dart:476:37

    ╷
476 │       if ((filters.value == null || filters.value?.length == 0) &&
    │                                     ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dropdown/dropdown_dialog.dart

INFO: Use 'isEmpty' instead of 'length' to test whether the collection is empty.

lib/src/dropdown/dropdown_dialog.dart:478:15

    ╷
478 │ ┌               (latestFutureSearchArgs![3] as List<Tuple2<String, String>>)
479 │ │                       .length ==
480 │ │                   0)) {
    │ └───────────────────^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dropdown/dropdown_dialog.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

512
likes
130
pub points
96%
popularity

Publisher

verified publisherjod.li

Highly customizable Widget to search through a single or multiple choices list in a dialog box or a menu. Supports pagination, future/API/webservice searches with sort and filter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on search_choices