sealed_class_generator 3.0.0 icon indicating copy to clipboard operation
sealed_class_generator: ^3.0.0 copied to clipboard

Sealed Class generator parses and generates your sealed classes.

3
likes
75/ 140
pub points
5%
popularity

We analyzed this package 11 hours ago, and awarded it 75 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
25 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No CHANGELOG.md found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:sealed_class_generator/sealed_class_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform iOS

Because:

  • package:sealed_class_generator/sealed_class_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Web

Because:

  • package:sealed_class_generator/sealed_class_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

lib/src/gen.dart:24:29

   ╷
24 │         .map((type) => type.name)
   │                             ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/gen.dart

INFO: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

lib/src/visitor.dart:9:43

  ╷
9 │       className = element.type.returnType.name;
  │                                           ^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/visitor.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.10.39.175.2.0
build^1.2.11.6.22.3.1
sealed_class^3.0.03.0.03.0.0
source_gen^0.9.4+60.9.10+21.2.6
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.050.0.0
args-1.6.02.3.1
async-2.10.02.10.0
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.11.1.1
collection-1.17.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
csslib-0.16.20.17.2
dart_style-1.3.62.2.4
file-5.2.16.1.4
glob-1.2.12.1.1
html-0.14.0+40.15.1
intl-0.17.00.17.0
js-0.6.50.6.5
logging-1.1.01.1.0
meta-1.8.01.8.0
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
package_config-1.9.32.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-0.9.7+151.0.2
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint ^0.39.1 on analyzer does not support the stable version 0.40.0.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint ^1.2.1 on build does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.6.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

3
likes
75
pub points
5%
popularity

Publisher

verified publisher iconvrt.be

Sealed Class generator parses and generates your sealed classes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

analyzer, build, sealed_class, source_gen

More

Packages that depend on sealed_class_generator