scrollable_list_tab_scroller 1.1.0 icon indicating copy to clipboard operation
scrollable_list_tab_scroller: ^1.1.0 copied to clipboard

Customizable Flutter widget which synchronize a scrollable grouped items list with tabs

35
likes
130/ 140
pub points
86%
popularity

We analyzed this package 15 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 52 API elements (32.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
easy_debounce^2.0.12.0.32.0.3
flutterflutter0.0.00.0.0
scrollable_positioned_list^0.3.50.3.50.3.5
scrolls_to_top^1.1.11.1.12.1.0
uuid^3.0.53.0.73.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
crypto-3.0.23.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.1` on scrolls_to_top does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions scrolls_to_top to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

35
likes
130
pub points
86%
popularity

Publisher

verified publisher iconrailson.dev

Customizable Flutter widget which synchronize a scrollable grouped items list with tabs

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

easy_debounce, flutter, scrollable_positioned_list, scrolls_to_top, uuid

More

Packages that depend on scrollable_list_tab_scroller