screwdriver 5.3.0 copy "screwdriver: ^5.3.0" to clipboard
screwdriver: ^5.3.0 copied to clipboard

A dart package aiming to provide useful extensions and helper functions to ease and speed up development.

74
likes
130/ 140
pub points
79%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

963 out of 975 API elements (98.8 %) have documentation comments.

Some symbols that are missing documentation: screwdriver, screwdriver.CanonicalizedMap.retype, screwdriver.DelegatingIterable.retype, screwdriver.DelegatingList.retype, screwdriver.DelegatingMap.retype.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/async/future.dart:35:1

   ╷
35 │ part of screwdriver;
   │ ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/async/future.dart

INFO: The part-of directive uses a library name.

lib/collection/comparable.dart:35:1

   ╷
35 │ part of screwdriver;
   │ ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/collection/comparable.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
characters >=1.3.0 <2.0.0 1.3.0 1.3.0
collection >=1.17.1 <2.0.0 1.18.0 1.18.0
intl >=0.18.0 <1.0.0 0.19.0 0.19.0
meta >=1.9.0 <2.0.0 1.12.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

74
likes
130
pub points
79%
popularity

Publisher

verified publisherbirju.dev

A dart package aiming to provide useful extensions and helper functions to ease and speed up development.

Repository (GitHub)
View/report issues
Contributing

Topics

#extensions #helpers #utility #utils

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

characters, collection, intl, meta

More

Packages that depend on screwdriver