schema_widget 1.0.0
schema_widget: ^1.0.0 copied to clipboard

The schema_widget flutter package is a widget generator based on JSON parsers capable of producing complex screens and using custom business rules.

5
likes
60 / 110
pub points
34 %
popularity

We analyzed this package on Apr 23, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 93 out of 101 API elements (92.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:schema_widget/schema_widget.dart that imports:
  • package:schema_widget/resolver/base_cache_manager_json_schema_resolver.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

ERROR: The named parameter 'resizeToAvoidBottomPadding' isn't defined.

lib/parser/scaffold_schema_widget_parser.dart:71:7

   ╷
71 │       resizeToAvoidBottomPadding: value['resizeToAvoidBottomPadding'],
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/parser/scaffold_schema_widget_parser.dart

ERROR: The named parameter 'darkColor' isn't defined.

lib/parser/type/flutter_logo_decoration_schema_parser.dart:41:7

   ╷
41 │       darkColor: SchemaWidget.parse<Color>(
   │       ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/parser/type/flutter_logo_decoration_schema_parser.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer<=0.39.140.39.141.5.0
build^1.3.01.6.22.0.1
flutterflutter0.0.00.0.0
flutter_cache_manager^1.4.11.4.23.0.1
get_it^4.0.44.0.46.1.1
glob^1.2.01.2.02.0.1
http^0.12.20.12.20.13.1
json_schema^2.2.12.2.12.2.1
logging^0.11.40.11.41.0.1
path^1.7.01.8.01.8.0
path_provider^1.6.141.6.282.0.1
rxdart^0.24.10.24.10.26.0
source_gen^0.9.60.9.10+21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-6.0.021.0.0
args-1.6.02.1.0
async-2.5.02.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
cli_repl-0.2.20.2.2
cli_util-0.1.40.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
colorize-2.0.03.0.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart2_constant-1.0.2+dart21.0.2+dart2
dart_style-1.3.62.0.0
ffi-1.0.01.0.0
file-5.2.16.1.0
fluri-1.3.02.0.0
html-0.14.0+40.15.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-0.9.71.0.0
node_interop-1.2.12.0.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
package_resolver-1.0.101.0.10
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-3.0.134.2.1
pub_semver-1.4.42.0.0
quiver-2.1.53.0.1
sass-1.32.81.32.11
sky_engine-0.0.990.0.99
sockjs_client-0.3.50.3.5
sockjs_client_wrapper-1.1.01.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+3
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
uri-0.11.41.0.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0
w_common-1.20.41.20.4
w_transport-3.2.83.2.8
watcher-0.9.7+151.0.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `<=0.39.14` on analyzer does not support the stable version `0.39.15`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.3.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

5
likes
60
pub points
34%
popularity

Publisher

legytma.com.br

The schema_widget flutter package is a widget generator based on JSON parsers capable of producing complex screens and using custom business rules.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

analyzer, build, flutter, flutter_cache_manager, get_it, glob, http, json_schema, logging, path, path_provider, rxdart, source_gen

More

Packages that depend on schema_widget