scanbot_sdk 1.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 92

Scanbot SDK Flutter Plugin #

Flutter plugin for the Scanbot Scanner SDK on Android and iOS.

Provides functionality like Document Scanning, Barcode and QR Code Scanning, Image Filtering, PDF Creation, Optical Character Recognition, etc.

For more details please see:

1.1.2 #

  • 🚀 Improvements:
    • OperationResult.CANCELED when the user presses cancel in any Scanbot UI screen component

1.1.1 #

  • 🐞 Bug fixes:
    • Android: Fixed a bug with mappings of OCR language data files (zh-Hans and zh-Hant to chi_sim.traineddata and chi_tra.traineddata).

1.1.0 #

  • 🎉 New:
    • Added further TIFF options dpi and compression. See createTiff(pages, options).
  • 🚀 Improvements:
    • Improved OCR API. The OCR results contain now bounding boxes and values of recognized words, lines and paragraphs. See the API docs of OcrResult.pages for more details.
  • 🐞 Bug fixes:
    • iOS: Fixed file URI handling in the native implementation of the createPage() method.

1.0.0 #

  • 🎉 First release

0.9.0-beta.7 #

  • Beta version

0.9.0-beta.6 #

  • First beta version

example/README.md

Usage sample #

Example application available on GitHub: scanbot-sdk-example-flutter

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scanbot_sdk: ^1.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scanbot_sdk/scanbot_sdk.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
85
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:scanbot_sdk/scanbot_sdk.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:scanbot_sdk/scanbot_sdk.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:scanbot_sdk/scanbot_sdk.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:scanbot_sdk/scanbot_sdk.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [scanbot_sdk] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
flutter 0.0.0
json_annotation ^3.0.0 3.0.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
build_runner ^1.0.0
flutter_test
json_serializable ^3.2.0