sane 1.0.1

Sane: Forus Labs' Core Dart Library #

Travis CI Codecov Pub Dev

Sane is Forus Labs' core library that includes annotations, collection types, date-times and utilities for numerics and strings.

This is a bleeding edge version of Sane. For a production ready and documented version, please refer to the stable branch.

sane.collection #

  • Delegating collection types
  • Observable collection types
  • Tuples (Pair, Triple and Quad)
  • Pseudo-weak collection types

sane.core #

  • Annotations (i.e. nullable, tainted)
  • Pseudo-weak reference
  • Utilities for numerics and strings

sane.time #

  • Distinct global and localized date-time types
  • Period type
  • Span type
  • Time type
  • Utilities for rounding date-times

1.0.1 - Fix me up, Scotty #

  • Fix GlobalDateTime.now() returning the incorrect date and time.

1.0.0 - Initial Launch! 🚀 #

  • Add collection library
  • Add core library
  • Add time library

example/README.md

Please refer to the wiki.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sane: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sane/sane.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Feb 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Format lib/core.dart.

Run dartfmt to format lib/core.dart.

Format lib/src/collection/delegate_list.dart.

Run dartfmt to format lib/src/collection/delegate_list.dart.

Format lib/src/collection/delegate_map.dart.

Run dartfmt to format lib/src/collection/delegate_map.dart.

Fix additional 20 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/collection/delegate_set.dart (Run dartfmt to format lib/src/collection/delegate_set.dart.)
  • lib/src/collection/observable_list.dart (Run dartfmt to format lib/src/collection/observable_list.dart.)
  • lib/src/collection/observable_map.dart (Run dartfmt to format lib/src/collection/observable_map.dart.)
  • lib/src/collection/observable_modification.dart (Run dartfmt to format lib/src/collection/observable_modification.dart.)
  • lib/src/collection/observable_set.dart (Run dartfmt to format lib/src/collection/observable_set.dart.)
  • lib/src/collection/tuples.dart (Run dartfmt to format lib/src/collection/tuples.dart.)
  • lib/src/collection/weak_map.dart (Run dartfmt to format lib/src/collection/weak_map.dart.)
  • lib/src/collection/weak_set.dart (Run dartfmt to format lib/src/collection/weak_set.dart.)
  • lib/src/core/annotations.dart (Run dartfmt to format lib/src/core/annotations.dart.)
  • lib/src/core/handles.dart (Run dartfmt to format lib/src/core/handles.dart.)
  • lib/src/core/listenable.dart (Run dartfmt to format lib/src/core/listenable.dart.)
  • lib/src/core/numerics.dart (Run dartfmt to format lib/src/core/numerics.dart.)
  • lib/src/core/strings.dart (Run dartfmt to format lib/src/core/strings.dart.)
  • lib/src/core/weak.dart (Run dartfmt to format lib/src/core/weak.dart.)
  • lib/src/time/date_time.dart (Run dartfmt to format lib/src/time/date_time.dart.)
  • lib/src/time/period.dart (Run dartfmt to format lib/src/time/period.dart.)
  • lib/src/time/span.dart (Run dartfmt to format lib/src/time/span.dart.)
  • lib/src/time/time.dart (Run dartfmt to format lib/src/time/time.dart.)
  • lib/src/time/weekdays.dart (Run dartfmt to format lib/src/time/weekdays.dart.)
  • lib/time.dart (Run dartfmt to format lib/time.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
meta ^1.1.7 1.1.8
Dev dependencies
flint ^1.0.4
mockito ^4.1.1
test ^1.9.4
test_coverage ^0.4.0