rp_web_ui 0.0.11

  • Readme
  • Changelog
  • Installing
  • 21

An absolute bare-bones web app.

Created from templates made available by Stagehand under a BSD-style license.

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rp_web_ui: ^0.0.11

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rp_web_ui/rp_web_ui.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
50
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
21
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.4

Health issues and suggestions

Fix lib/routes.dart. (-43.75 points)

Analysis of lib/routes.dart failed with 2 errors:

line 6 col 8: Target of URI hasn't been generated: 'storybook/rp_range_book/rp_range_book.template.dart'.

line 7 col 8: Target of URI hasn't been generated: 'storybook/rp_modal_book/rp_modal_book.template.dart'.

Fix lib/components/rp_range/rp_range.dart. (-5.36 points)

Analysis of lib/components/rp_range/rp_range.dart reported 11 hints, including:

line 4 col 8: Unused import: 'package:stream_transform/stream_transform.dart'.

line 78 col 10: The value of the field '_moveFromPosition' isn't used.

line 79 col 10: The value of the field '_moveToPosition' isn't used.

line 80 col 10: The value of the field '_zoomPosition' isn't used.

line 91 col 7: The value of the field '_centerBtnPossitionEnd' isn't used.

Fix lib/components/rp_modal/rp_modal.dart. (-2.96 points)

Analysis of lib/components/rp_modal/rp_modal.dart reported 6 hints, including:

line 53 col 17: Avoid const keyword.

line 71 col 12: Avoid return types on setters.

line 74 col 11: Unnecessary new keyword.

line 107 col 22: Unnecessary new keyword.

line 115 col 5: Unnecessary new keyword.

Fix additional 4 files with analysis or formatting issues. (-3.49 points)

Additional issues in the following files:

  • lib/storybook/rp_modal_book/rp_modal_book.dart (3 hints)
  • lib/rp_web_ui.dart (2 hints)
  • lib/storybook/rp_range_book/rp_range_book.dart (2 hints)
  • lib/index.dart (Run dartfmt to format lib/index.dart.)

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://bitbucket.org/simplexios/roadmap_planner_web_ui_components/src was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (stream_transform).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and rp_web_ui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
angular ^5.2.0 5.3.1 6.0.0-alpha+1
angular_router ^2.0.0-alpha+21 2.0.0-alpha+22 2.0.0-alpha+24
stream_transform ^0.0.16 0.0.20 1.1.0
Transitive dependencies
analyzer 0.35.4 0.39.4
angular_ast 0.5.9 0.5.11
angular_compiler 0.4.3 0.4.5
args 1.5.2
async 2.4.0
build 1.2.2
build_config 0.4.1+1
built_collection 4.3.2
built_value 7.0.8
charcode 1.1.2
checked_yaml 1.0.2
code_builder 3.2.1
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.14.6+1 0.16.1
fixnum 0.10.11
front_end 0.1.14 0.1.29
glob 1.2.0
intl 0.15.8 0.16.1
json_annotation 3.0.1
kernel 0.3.14 0.3.29
logging 0.11.4
matcher 0.12.6
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0 2.0.0
path 1.6.4
pub_semver 1.4.2
pubspec_parse 0.1.5
quiver 2.1.2+1
source_gen 0.9.4+4 0.9.4+7
source_span 1.6.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0
Dev dependencies
angular_test ^2.2.0
build_runner ^1.1.2
build_test ^0.10.3
build_web_compilers ^1.0.0
built_value_generator ^6.3.1
coverage ^0.12.4
dart_dev ^2.0.3
dart_style ^1.2.3 1.2.4 1.3.3
dartdoc ^0.28.0
js ^0.6.0 0.6.1+1
pedantic ^1.0.0 1.9.0
sass_builder ^2.0.0
test ^1.5.1