routemaster 1.0.1 copy "routemaster: ^1.0.1" to clipboard
routemaster: ^1.0.1 copied to clipboard

Easy-to-use Navigator 2.0 router for web, mobile and desktop. URL-based routing, simple navigation of tabs and nested routes.

633
likes
110/ 140
pub points
96%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

237 out of 238 API elements (99.6 %) have documentation comments.

Some symbols that are missing documentation: routemaster.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/route_data.dart:176:25

    ╷
176 │       routeInfo.location!,
    │                         ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/route_data.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/route_data.dart:177:39

    ╷
177 │       pathTemplate: routeInfo.location!,
    │                                       ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/route_data.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

633
likes
110
pub points
96%
popularity

Publisher

verified publishertom.gilder.dev

Easy-to-use Navigator 2.0 router for web, mobile and desktop. URL-based routing, simple navigation of tabs and nested routes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter, flutter_web_plugins, path

More

Packages that depend on routemaster