round_corners_image_provider 0.0.1 icon indicating copy to clipboard operation
round_corners_image_provider: ^0.0.1 copied to clipboard

A new Flutter package project.

4
likes
85/ 140
pub points
21%
popularity

We analyzed this package 2 days ago, and awarded it 85 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

README.md contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 83 API elements (25.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:round_corners_image_provider/round_corners_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.

Package does not support platform Linux.

Because:

  • package:round_corners_image_provider/round_corners_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.

Package does not support platform Web.

Because:

  • package:round_corners_image_provider/round_corners_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/image_provider.dart:41:3

   ╷
41 │ ┌   /**
42 │ │    * 设置圆角
43 │ └    */
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/image_provider.dart

INFO: 'DecoderCallback' is deprecated and shouldn't be used. Use DecoderBufferCallback with ImageProvider.loadBuffer instead. This feature was deprecated after v2.13.0-1.0.pre..

lib/image_provider.dart:281:34

    ╷
281 │   ImageStreamCompleter load(key, DecoderCallback decode) {
    │                                  ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/image_provider.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.5.02.5.13.2.3
flutterflutter0.0.00.0.0
flutter_cache_manager^2.1.12.1.23.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.53.3.5
async-2.10.02.10.0
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.16.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_blurhash-0.5.00.7.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
image-3.2.23.2.2
js-0.6.50.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
octo_image-0.3.01.0.2
path-1.8.21.8.2
path_provider-2.0.112.0.11
path_provider_android-2.0.222.0.22
path_provider_ios-2.0.112.0.11
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
pedantic-1.11.11.11.1
petitparser-5.1.05.1.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
pointycastle-3.6.23.6.2
process-4.2.44.2.4
rxdart-0.25.00.27.7
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
sqflite-2.2.0+32.2.0+3
sqflite_common-2.4.0+22.4.0+2
string_scanner-1.2.01.2.0
synchronized-3.0.0+33.0.0+3
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-3.0.73.0.7
vector_math-2.1.22.1.4
win32-3.1.23.1.2
xdg_directories-0.2.0+20.2.0+2
xml-6.1.06.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^2.5.0 on cached_network_image does not support the stable version 3.0.0.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint ^2.1.1 on flutter_cache_manager does not support the stable version 3.0.0.

Try running dart pub upgrade --major-versions flutter_cache_manager to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.