rolling_tab_bar 0.0.1-alpha-1

rolling_nav_bar #

Misnamed verison of RollingNavBar. #lol

Getting Started #

To start, click the RollingNavBar link above and use that.

[0.0.1-alpha-1] - 2019-12-15

  • Realized name was incorrect and updated README.

[0.0.1-alpha] - 2019-12-15

  • Initial release of RollingNavBar with four animation types: roll, snap, fade-out-and-in, and spin-out-and-in


example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  rolling_tab_bar: ^0.0.1-alpha-1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:rolling_tab_bar/indexed.dart';
import 'package:rolling_tab_bar/rolling_nav_bar.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/rolling_nav_bar.dart.

Run flutter format to format lib/rolling_nav_bar.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
polygon_clipper ^1.0.2 1.0.2
tinycolor ^1.0.2 1.0.2
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
pigment 1.0.3
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies