roggle 0.4.2+1 copy "roggle: ^0.4.2+1" to clipboard
roggle: ^0.4.2+1 copied to clipboard

Simple, colorful and easy to expand logger for dart. Inspired by the logger and dependent to the logger.

27
likes
130/ 140
pub points
78%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

98 out of 179 API elements (54.7 %) have documentation comments.

Some symbols that are missing documentation: roggle, roggle.AnsiColor.AnsiColor.bg, roggle.AnsiColor.bg, roggle.AnsiColor.call, roggle.AnsiColor.color.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:roggle/roggle.dart that imports:
  • package:roggle/src/roggle.dart that imports:
  • package:roggle/src/printers/single_pretty_printer.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/file_output_stub.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
logger 2.0.2+1 2.0.2+1 2.3.0
meta ^1.7.0 1.15.0 1.15.0
stack_trace ^1.10.0 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `2.0.2+1` on logger does not support the stable version `2.1.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

27
likes
130
pub points
78%
popularity
screenshot

Publisher

verified publisherkeyber.jp

Simple, colorful and easy to expand logger for dart. Inspired by the logger and dependent to the logger.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

logger, meta, stack_trace

More

Packages that depend on roggle