rikulo_ui 0.8.0

  • README.md
  • Installing
  • Versions
  • 9

#Rikulo UI

Rikulo UI is a cross-platform framework for creating amazing Web and native mobile applications in Dart and HTML 5. Our aim is to bring structure to your user interface with a strong layout system, recursive component composition, and neat libraries.

You can access your application directly with a modern Web browser without any plug-in. You can also build it as a native mobile application accessing the device's resources transparently.

Rikulo is distributed under an Apache 2.0 License.

Build Status

##Installation

Add this to your pubspec.yaml (or create it):

dependencies:
  rikulo_ui:

Then run the Pub Package Manager (comes with the Dart SDK):

pub install

For more information, please refer to Rikulo: Getting Started and Pub: Getting Started.

##Usage

Creating UI in Rikulo is straightforward.

import 'package:rikulo_ui/view.dart';

void main() {
  new TextView("Hello World!") //create UI
    .addToDocument(); //make it available to the browser
}

For more information, please refer to the Hello World sample application.

##Notes to Contributors

###Create Addons

Rikulo is easy to extend. The simplest way to enhance Rikulo is to create a new repository and add your own great widgets and libraries to it.

###Fork Rikulo

If you'd like to contribute back to the core, you can fork this repository and send us a pull request, when it is ready.

Please be aware that one of Rikulo's design goals is to keep the sphere of API as neat and consistency as possible. Strong enhancement always demands greater consensus.

If you are new to Git or GitHub, please read this guide first.

##Development Notes

###Compile LESS to CSS

Rikulo CSS rules are placed in view.less. They are written in LESS. If you modify view.less, you have to invoke tool/l2c to generate view.css (under Linux or Cygwin bash).

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rikulo_ui: ^0.8.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rikulo_ui/effect.dart';
import 'package:rikulo_ui/event.dart';
import 'package:rikulo_ui/gesture.dart';
import 'package:rikulo_ui/html.dart';
import 'package:rikulo_ui/layout.dart';
import 'package:rikulo_ui/message.dart';
import 'package:rikulo_ui/model.dart';
import 'package:rikulo_ui/view.dart';
  
Version Uploaded Documentation Archive
0.8.0 Nov 25, 2015 Go to the documentation of rikulo_ui 0.8.0 Download rikulo_ui 0.8.0 archive
0.7.3+1 Jan 9, 2014 Go to the documentation of rikulo_ui 0.7.3+1 Download rikulo_ui 0.7.3+1 archive
0.7.3 Oct 29, 2013 Go to the documentation of rikulo_ui 0.7.3 Download rikulo_ui 0.7.3 archive
0.7.2 Oct 24, 2013 Go to the documentation of rikulo_ui 0.7.2 Download rikulo_ui 0.7.2 archive
0.7.1 Oct 8, 2013 Go to the documentation of rikulo_ui 0.7.1 Download rikulo_ui 0.7.1 archive
0.7.0+2 Sep 17, 2013 Go to the documentation of rikulo_ui 0.7.0+2 Download rikulo_ui 0.7.0+2 archive
0.7.0+1 Sep 17, 2013 Go to the documentation of rikulo_ui 0.7.0+1 Download rikulo_ui 0.7.0+1 archive
0.7.0 Sep 9, 2013 Go to the documentation of rikulo_ui 0.7.0 Download rikulo_ui 0.7.0 archive
0.6.8+2 Aug 27, 2013 Go to the documentation of rikulo_ui 0.6.8+2 Download rikulo_ui 0.6.8+2 archive
0.6.8 Jul 18, 2013 Go to the documentation of rikulo_ui 0.6.8 Download rikulo_ui 0.6.8 archive

All 33 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
9
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0