rich_link_preview 0.1.4

Flutter Android iOS web

A Rich Link Preview widget written in Dart generating a rich presentation of the given link from social meta tags.

9
likes
100 / 110
pub points
63 %
popularity

We analyzed this package on Oct 31, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 11 API elements (9.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
open_graph_parser^0.0.40.0.60.0.6
url_launcher^5.0.05.7.85.7.8
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
csslib-0.15.00.16.2
flutter_web_plugins-0.0.00.0.0
html-0.13.4+20.14.0+4
http-0.12.00.12.2
http_parser-3.1.43.1.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
path-1.7.01.7.0
plugin_platform_interface-1.0.31.0.3
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
url_launcher_linux-0.0.1+30.0.1+3
url_launcher_macos-0.0.1+80.0.1+8
url_launcher_platform_interface-1.0.91.0.9
url_launcher_web-0.1.50.1.5
url_launcher_windows-0.0.1+10.0.1+1
utf-0.9.0+50.9.0+5
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
100
pub points
63%
popularity

A Rich Link Preview widget written in Dart generating a rich presentation of the given link from social meta tags.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

wingkwong.code@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, open_graph_parser, url_launcher

More

Packages that depend on rich_link_preview