rethinkdb_dart 2.3.2+6

Dart native
Flutter Android iOS

Dart 2 driver for RethinkDB v2.3.

13
likes
65 / 110
pub points
59 %
popularity

We analyzed this package on Oct 30, 2020, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 3 links are insecure.

README.md:3:6

  ╷
3 │ <p>A <a href="http://www.dartlang.org">Dart 2</a> and <a href="https://flutter.io">Flutter</a> driver for <a href="http://www.rethinkdb.com">RethinkDB v2.3</a>.</p>
  │      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 55 out of 1064 API elements (5.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:rethinkdb_dart/rethinkdb_dart.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.12.1.1
crypto^2.0.62.1.52.1.5
pbkdf2_dart^2.1.02.1.02.1.0
protobuf^0.13.150.13.16+11.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
fixnum-0.10.110.10.11
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.15` on protobuf does not support the latest published version `1.1.0`

pubspec.yaml:12:13

   ╷
12 │   protobuf: ^0.13.15
   │             ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs