restio_retrofit 0.3.0
restio_retrofit: ^0.3.0 copied to clipboard

HTTP client generator for Restio inspired by Retrofit.

2
likes
70 / 130
pub points
3 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 43 out of 121 API elements (35.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:restio_retrofit/restio_retrofit.dart that imports:
  • package:restio_retrofit/src/annotations.dart that imports:
  • package:restio/restio.dart that imports:
  • package:restio/src/retrofit/result.dart that imports:
  • package:restio/src/core/request/header/headers.dart that imports:
  • package:restio/src/core/request/header/headers_builder.dart that imports:
  • package:restio/src/core/request/header/header.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/retrofit.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.100.39.172.0.0
build^1.3.01.3.02.0.3
build_runner^1.10.01.10.22.0.6
code_builder^3.3.03.7.04.1.0
dart_style^1.3.61.3.62.0.3
meta^1.1.81.7.01.7.0
restio^0.10.10.10.110.10.11
source_gen^0.9.50.9.7+11.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.023.0.0
args-1.6.02.2.0
async-2.8.12.8.1
brotli-0.3.0+10.5.0
build_config-0.4.21.0.0
build_daemon-2.1.103.0.0
build_resolvers-1.3.112.0.4
build_runner_core-6.0.17.0.1
built_collection-4.3.25.1.0
built_value-7.1.08.1.1
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.3
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.0
equatable-1.2.62.0.3
file-5.2.16.1.2
fixnum-0.10.111.0.0
glob-1.2.02.0.1
globbing-0.3.11.0.0
graphs-0.2.02.0.0
html-0.14.0+40.15.0
http2-1.0.12.0.0
http_multi_server-2.2.03.0.1
http_parser-3.1.44.0.0
intl-0.17.00.17.0
io-0.3.51.0.3
ip-0.1.10.1.1
js-0.6.30.6.3
json_annotation-3.1.14.1.0
logging-0.11.41.0.1
matcher-0.12.100.12.10
mime-0.9.71.0.0
mime_type-0.3.21.0.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pool-1.5.01.5.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
quiver-2.1.53.0.1
raw-0.2.00.2.0
shelf-0.7.91.2.0
shelf_web_socket-0.2.4+11.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-1.2.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
utf-0.9.0+50.9.0+5
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.1.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.39.10` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.3.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

2
likes
70
pub points
3%
popularity

Publisher

tiagohm.dev

HTTP client generator for Restio inspired by Retrofit.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, build_runner, code_builder, dart_style, meta, restio, source_gen

More

Packages that depend on restio_retrofit