responsive_scaffold 1.3.0+2
responsive_scaffold: ^1.3.0+2 copied to clipboard

On mobile it shows a list and pushes to details and on tablet it shows the List and the selected item.

128
likes
60 / 130
pub points
81 %
popularity

We analyzed this package on May 12, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 165 API elements (6.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

ERROR: The named parameter 'resizeToAvoidBottomPadding' isn't defined.

lib/templates/list/responsive_list.dart:217:11

    ╷
217 │           resizeToAvoidBottomPadding: resizeToAvoidBottomPadding,
    │           ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/templates/list/responsive_list.dart

ERROR: The named parameter 'resizeToAvoidBottomPadding' isn't defined.

lib/templates/list/views/tablet.dart:188:15

    ╷
188 │               resizeToAvoidBottomPadding: widget?.resizeToAvoidBottomPadding,
    │               ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/templates/list/views/tablet.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
scroll_to_index^1.0.51.0.62.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.5` on scroll_to_index does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions scroll_to_index to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

128
likes
60
pub points
81%
popularity

Publisher

fluttercommunity.dev

On mobile it shows a list and pushes to details and on tablet it shows the List and the selected item.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, scroll_to_index

More

Packages that depend on responsive_scaffold