request_extras 1.0.0 copy "request_extras: ^1.0.0" to clipboard
request_extras: ^1.0.0 copied to clipboard

Useful utility extension methods on the Dart Sdk HttpRequest class for getting and setting headers.

0
likes
15/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 15 pub points (of a possible 140):

failed
Follow Dart file conventions
5 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/TechSar-dev/request_extras was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: request_extras,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:34:49

   ╷
34 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.6.0-dev.8.1 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.0. Cannot run `dart pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.6.0-dev.8.1 <3.0.0'
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.0.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.6.0-dev.8.1 <3.0.0'
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

0
likes
15
pub points
0%
popularity

Publisher

verified publishertechstar.dev

Useful utility extension methods on the Dart Sdk HttpRequest class for getting and setting headers.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

More

Packages that depend on request_extras