repo_case_generator 0.1.2
repo_case_generator: ^0.1.2 copied to clipboard

Generator package for repo_case to to auto-generate use cases classes from your repository signature class

1
likes
90 / 130
pub points
14 %
popularity

We analyzed this package on May 7, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:repo_case_generator/builder.dart that imports:
  • package:repo_case_generator/src/repo_case_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.60.40.61.5.0
build>=0.12.6 <2.0.01.6.22.0.1
path^1.7.01.8.01.8.0
repo_case^0.1.20.1.20.1.2
source_gen^0.9.60.9.10+21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.021.0.0
args-1.6.02.1.0
async-2.6.12.6.1
boolean_selector-2.1.02.1.0
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
coverage-0.15.21.0.2
crypto-2.1.53.0.1
dart_style-1.3.102.0.1
file-5.2.16.1.0
glob-1.2.02.0.1
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
intl-0.17.00.17.0
io-1.0.01.0.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
node_preamble-1.4.132.0.0
package_config-1.9.32.0.0
pedantic-1.11.01.11.0
pool-1.5.01.5.0
pub_semver-1.4.42.0.0
shelf-1.1.11.1.1
shelf_packages_handler-2.0.13.0.0
shelf_static-0.2.9+21.0.0
shelf_web_socket-0.2.4+11.0.1
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.2.190.4.0
test_core-0.3.150.3.23
typed_data-1.3.01.3.0
vm_service-6.2.06.2.0
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.1.0
webkit_inspection_protocol-1.0.01.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.40.6` on analyzer does not support the stable version `0.41.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=0.12.6 <2.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

1
likes
90
pub points
14%
popularity

Publisher

sandromaglione.com

Generator package for repo_case to to auto-generate use cases classes from your repository signature class

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, path, repo_case, source_gen

More

Packages that depend on repo_case_generator