rename 1.3.0
rename: ^1.3.0 copied to clipboard

Helps you to change or rename your flutter project BundleId and AppName for Ios, Android, MacOS and Linux platforms

123
likes
70 / 110
pub points
91 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 49 API elements (2.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:rename/rename.dart that imports:
  • package:rename/file_repository.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: This function has a return type of 'FutureOr

lib/file_repository.dart:33:16

   ╷
33 │   Future<File> changeLauncherIcon({String base64String}) async {
   │                ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/file_repository.dart

INFO: The value of the local variable 'writtenFile' isn't used.

lib/file_repository.dart:242:10

    ╷
242 │     File writtenFile = await writeFile(
    │          ^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/file_repository.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.02.0.0
logger^0.9.10.9.41.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.9.1` on logger does not support the stable version `1.0.0`, that was published 20 days ago.

When logger is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

123
likes
70
pub points
91%
popularity

Publisher

onatcipli.com

Helps you to change or rename your flutter project BundleId and AppName for Ios, Android, MacOS and Linux platforms

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, logger

More

Packages that depend on rename