remote_state 2.0.0 copy "remote_state: ^2.0.0" to clipboard
remote_state: ^2.0.0 copied to clipboard

Tools for mapping data from remote sources in Dart, similar to Elm's RemoteData.

7
likes
110/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

14 out of 15 API elements (93.3 %) have documentation comments.

Some symbols that are missing documentation: remote_state.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/remote_state.freezed.dart:126:17

    ╷
126 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/remote_state.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/remote_state.freezed.dart:218:17

    ╷
218 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/remote_state.freezed.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
freezed_annotation ^0.14.0 0.14.3 2.4.1
meta >=1.0.0 <3.0.0 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
json_annotation - 4.9.0 4.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0` on freezed_annotation does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

7
likes
110
pub points
0%
popularity

Publisher

verified publishercancode.dev

Tools for mapping data from remote sources in Dart, similar to Elm's RemoteData.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

freezed_annotation, meta

More

Packages that depend on remote_state