reframe_middleware 1.0.1
reframe_middleware: ^1.0.1 copied to clipboard

Clojurescript re-frame middleware for redux-dart

0
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on May 13, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 25 API elements (4.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/action.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/middleware.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.2.31.3.01.3.0
quiver^2.1.32.1.53.0.1
redux^4.0.04.0.0+35.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.100.12.10
path-1.8.01.8.0
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.3` on quiver does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver to update the constraint.

The constraint `^4.0.0` on redux does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions redux to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
60
pub points
0%
popularity

Publisher

chrisclampitt.life

Clojurescript re-frame middleware for redux-dart

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

meta, quiver, redux

More

Packages that depend on reframe_middleware