redstone_database_mongo 0.5.0

  • Readme
  • Changelog
  • Installing
  • 0

redstone_database_mongo #

Build Status Pub version

redstone_database_mongo is a fork of redstone_mapper_mongo.

See examples/server_example.dart for usage.

Changelog #

0.5.0 #

  • Align with dart 2

0.4.0 #

  • Update to redstone_database_plugin 0.3.0

0.3.0 #

  • Add getLastError method
  • Possible encoding shortcut by passing 'null' as Type

0.2.0 #

  • Update to serializer 0.5.0

Breaking changes:

  • Use serializer_codegen for serialization
  • Use a fork of redstone with updated DI

0.1.4 #

  • Set serializer as private into MongoDb

0.1.3+1 #

  • Remove cast on object for save, insert and insertAll (could be a Map)

0.1.3 #

  • Align with serializer version 0.4.2
  • Add dynamic serialization

0.1.2+1 #

  • Updated object can be Map or ModifierBuilder, not only Serializable object

0.1.2 #

  • Add closeConnections in MongoDbManager
  • Add optional writeConcern parameter in MongoDbManager
  • Add optional writeConcern parameter in MongoDBService and its atomic operations

0.1.1 #

  • Implement partial update (using '$set')

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  redstone_database_mongo: ^0.5.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:redstone_database_mongo/driver.dart';
import 'package:redstone_database_mongo/manager.dart';
import 'package:redstone_database_mongo/service.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.67.0 <2.0.0