redstone_database_plugin 0.4.0

redstone_database_plugin #

Build Status Pub version

redstone_database_plugin is a fork of redstone_mapper.

redstone_database_plugin is a set of utilities for handling common tasks including:

  • Encoding and decoding of objects with serializer.
  • Database connection management.
  • Encoding and decoding of objects to the database.

See examples/server_example.dart for usage.

Changelog #

0.4.0 #

  • Align with dart 2

0.3.0 #

  • Add DataLogger

0.2.1 #

  • Fix issue decoding List

0.2.0 #

  • Update to serializer 0.5.0

Breaking changes:

  • Use a fork of redstone with updated DI

0.1.5 #

  • Add serializer parameter in getDatabasePlugin

0.1.4 #

  • Fix query parameters decoding

0.1.3 #

  • Prefer to throw exception instead of sending an error response during serialization

0.1.2 #

  • Add useTypeInfo field in Decode/Encode annotations

0.1.1 #

  • Encode response as Map or List (toPrimaryObject instead of encode)

0.1.0+1 #

  • Fix typo

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  redstone_database_plugin: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:redstone_database_plugin/database.dart';
import 'package:redstone_database_plugin/plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.67.0 <2.0.0