red5pro 0.0.46 copy "red5pro: ^0.0.46" to clipboard
red5pro: ^0.0.46 copied to clipboard

Red5Pro Streaming & Player

6
likes
105/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 105 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/freshcodestechnology/red5pro was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: red5pro,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

0/5 points: Provide a valid README.md

`README.md` is empty.

The README.md file should inform others about your project, what it does, and how they can use it. Check out the guidelines on Writing great package pages.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

5 out of 59 API elements (8.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: red5_configuration, red5_configuration.R5StreamProtocol, red5_configuration.R5StreamProtocol.R5StreamProtocol, red5_configuration.Red5Configuration, red5_configuration.Red5Configuration.Red5Configuration.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:red5pro/red5pro.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:red5pro/red5pro.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:red5pro/red5pro.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:red5pro/red5pro.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Use the generic function type syntax in 'typedef's.

lib/red5_stream_player_view.dart:9:14

  ╷
9 │ typedef void R5StreamPlayerViewCallback(
  │              ^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/red5_stream_player_view.dart

INFO: Use the generic function type syntax in 'typedef's.

lib/red5_stream_view.dart:6:14

  ╷
6 │ typedef void R5StreamViewCallback(R5StreamViewController controller);
  │              ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/red5_stream_view.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.