recipe_flavored_markdown 1.0.0 copy "recipe_flavored_markdown: ^1.0.0" to clipboard
recipe_flavored_markdown: ^1.0.0 copied to clipboard

Recipe-flavored markdown: make recipes easy to create and maintain!

3
likes
110/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

42 out of 53 API elements (79.2 %) have documentation comments.

Some symbols that are missing documentation: recipe_flavored_markdown, recipe_flavored_markdown.RecipeHtmlRenderer.buffer, recipe_flavored_markdown.RecipeHtmlRenderer.render, recipe_flavored_markdown.RecipeHtmlRenderer.uniqueIds, recipe_flavored_markdown.Reference.accept.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Doc directive is missing a closing tag.

lib/src/recipe_nodes.dart:3:5

  ╷
3 │ /// {@template recipe_node_visitor}
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/recipe_nodes.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
markdown ^4.0.1 4.0.1 7.2.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
charcode - 1.3.1 1.3.1
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.1` on markdown does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions markdown to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

3
likes
110
pub points
0%
popularity

Publisher

verified publisheravataronline.live

Recipe-flavored markdown: make recipes easy to create and maintain!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

markdown

More

Packages that depend on recipe_flavored_markdown