reactive_sf_signaturepad 2.0.0 copy "reactive_sf_signaturepad: ^2.0.0" to clipboard
reactive_sf_signaturepad: ^2.0.0 copied to clipboard

Wrapper around syncfusion_flutter_signaturepad to use with reactive_forms.

1
likes
130/ 140
pub points
26%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

45 out of 47 API elements (95.7 %) have documentation comments.

Some symbols that are missing documentation: reactive_sf_signaturepad, reactive_sf_signaturepad.decorationInvisible.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
reactive_forms ^16.0.0 16.1.1 16.1.1
syncfusion_flutter_signaturepad ^22.1.36 22.2.12 24.2.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
syncfusion_flutter_core - 22.2.12 24.2.8
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^22.1.36` on syncfusion_flutter_signaturepad does not support the stable version `23.1.36`.

Try running dart pub upgrade --major-versions syncfusion_flutter_signaturepad to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.