reactive_range_slider 2.0.0 copy "reactive_range_slider: ^2.0.0" to clipboard
reactive_range_slider: ^2.0.0 copied to clipboard

Wrapper around RangeSlider to use with reactive_forms.

1
likes
130/ 140
pub points
69%
popularity

We analyzed this package 15 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 11 API elements (81.8 %) have documentation comments.

Some symbols that are missing documentation: reactive_range_slider, reactive_range_slider.ReactiveRangeSliderLabelBuilder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
reactive_forms ^16.0.0 16.1.1 17.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^16.0.0` on reactive_forms does not support the stable version `17.0.0`, that was published 19 days ago.

When reactive_forms is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions reactive_forms to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

1
likes
130
pub points
69%
popularity

Publisher

unverified uploader

Wrapper around RangeSlider to use with reactive_forms.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, reactive_forms

More

Packages that depend on reactive_range_slider