rdkr_widgets 0.0.1+1-alpha copy "rdkr_widgets: ^0.0.1+1-alpha" to clipboard
rdkr_widgets: ^0.0.1+1-alpha copied to clipboard

Collection of useful flutter widgets.

0
likes
20/ 140
pub points
0%
popularity

We analyzed this package 10 hours ago, and awarded it 20 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/philippredeker/Documents/sdk/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/philippredeker/Documents/sdk/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/philippredeker/Documents/sdk/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/philippredeker/Documents/sdk/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/philippredeker/Documents/sdk/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/philippredeker/Documents/sdk/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/philippredeker/Documents/sdk/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/philippredeker/Documents/sdk/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/philippredeker/Documents/sdk/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/philippredeker/Documents/sdk/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/philippredeker/Documents/sdk/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/philippredeker/Documents/sdk/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.0. Cannot run `flutter pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.0.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.3.0)

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.1, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.