rare_print 0.1.2
rare_print: ^0.1.2 copied to clipboard

Print Lib

1
likes
100/ 130
pub points
0%
popularity

We analyzed this package 40 hours ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 134 out of 518 API elements (25.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

lib/controls/barcode_box.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/controls/column_box.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
decimal^1.0.01.5.02.0.0
enough_convert^1.1.01.4.01.4.0
expressions^0.2.00.2.30.2.3
flutterflutter0.0.00.0.0
intl^0.17.00.17.00.17.0
qr^2.0.02.1.03.0.0
xml^5.0.25.3.15.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
fake_async-1.2.01.2.0
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
petitparser-4.4.04.4.0
quiver-3.0.1+13.0.1+1
rational-1.2.12.0.0
rxdart-0.27.30.27.3
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on decimal does not support the stable version `2.0.0`, that was published 3 days ago.

When decimal is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions decimal to update the constraint.

The constraint `^2.0.0` on qr does not support the stable version `3.0.0`, that was published 19 days ago.

When qr is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions qr to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.