range_header 2.0.2+2
range_header: ^2.0.2+2 copied to clipboard

Dart native
Flutter Android iOS

Range header parser for Dart. Beyond parsing, a stream transformer is included.

0
likes
90 / 110
pub points
68 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 25 API elements (56.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:range_header/range_header.dart that imports:
  • package:range_header/src/converter.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 61 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/converter.dart:22:13

   ╷
22 │       throw new ArgumentError('`header` cannot be null or empty.');
   │             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/converter.dart

INFO: Unnecessary new keyword.

lib/src/converter.dart:62:16

   ╷
62 │     var ctrl = new StreamController<List<int>>();
   │                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/converter.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.0.02.4.22.4.2
charcode^1.0.01.1.31.1.3
quiver_hashcode^2.0.02.0.02.0.0
source_span^1.0.01.7.01.7.0
string_scanner^1.0.01.0.51.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.14.131.14.13
meta-1.2.41.2.4
path-1.7.01.7.0
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
68%
popularity

Range header parser for Dart. Beyond parsing, a stream transformer is included.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

async, charcode, quiver_hashcode, source_span, string_scanner

More

Packages that depend on range_header