random_data 1.5.9
random_data: ^1.5.9 copied to clipboard

Generates random numbers, dates, strings, characters, names, durations, etc.

2
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 125 API elements (0.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
english_words^3.1.53.1.54.0.0
faker^1.1.01.3.02.0.0
random_words^1.0.21.0.21.0.2
string_unescape^1.5.11.5.12.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.1.5` on english_words does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions english_words to update the constraint.

The constraint `^1.1.0` on faker does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions faker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

2
likes
80
pub points
0%
popularity

Generates random numbers, dates, strings, characters, names, durations, etc.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

english_words, faker, random_words, string_unescape

More

Packages that depend on random_data