radix 1.0.2 copy "radix: ^1.0.2" to clipboard
radix: ^1.0.2 copied to clipboard

Dart library for base arithmetic. It handles basic arithmetic operations as well as parsing and conversion on decimal.

0
likes
30/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 30 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/Clique-Paris/dart-radix was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/Clique-Paris/dart-radix was unreachable. Make sure that the website is reachable via HEAD requests.

Documentation URL doesn't exist.

At the time of the analysis https://github.com/Clique-Paris/dart-radix/blob/master/README.md was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: radix,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.8.1 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.0. Cannot run `dart pub outdated`.

pubspec.yaml:9:8

  ╷
9 │   sdk: '>=2.8.1 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.0.

pubspec.yaml:9:8

  ╷
9 │   sdk: '>=2.8.1 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
30
pub points
0%
popularity

Publisher

verified publishermakepad.fr

Dart library for base arithmetic. It handles basic arithmetic operations as well as parsing and conversion on decimal.

Repository (GitHub)
View/report issues

Documentation

Documentation

License

MIT (LICENSE)

More

Packages that depend on radix