r_upgrade 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 67

r_upgrade #

pub package

Android and IOS upgrade plugin.

Getting Started #

  • use plugin: add this code in pubspec.yaml
dependencies:
  r_upgrade: last version
  • add listener
RUpgrade.stream.listen((info){
  ///...
});
  • just upgrade your android application
    void upgrade() async {
      int id = await RUpgrade.upgrade(
                 'https://raw.githubusercontent.com/rhymelph/r_upgrade/master/apk/app-release.apk',
                 apkName: 'app-release.apk');
    }
  • you can use this id to cancel download
    void cancel() async {
      bool isSuccess=await RUpgrade.cancel(id);
    }
  • you can use this id to install apk
    void install() async {
      bool isSuccess=await RUpgrade.install(id);
    }
  • your application is ios.You can use this.
    void iosUpgrade(String url)async{
      RUpgrade.appStore
    }

0.1.1 #

  • add ios upgrade from AppStore.

0.1.0 #

  • fix install apk.

0.0.2 #

  • Improving health.

0.0.1 #

  • release plugin.

example/README.md

r_upgrade_example #

Demonstrates how to use the r_upgrade plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  r_upgrade: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:r_upgrade/r_upgrade.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test