r_assets 0.2.4
r_assets: ^0.2.4 copied to clipboard

auto generate R file; like android R file;

1
likes
50/ 130
pub points
0%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 71 out of 224 API elements (31.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:r_assets/cli/cli_utils.dart that imports:
  • package:r_assets/mirror_visitor.dart that imports:
  • package:r_assets/logger/log.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

lib/cli/cli_utils.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/demo_plugin.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.170.39.172.7.0
analyzer_plugin^0.3.00.3.00.8.0
basic_utils^3.1.03.1.03.9.1
glob^1.2.01.2.02.0.2
json2yaml^2.0.02.0.03.0.0
path^1.8.01.8.01.8.0
pub_semver^1.4.41.4.42.1.0
quick_log^5.2.15.2.15.2.1
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.030.0.0
args-1.6.02.3.0
async-2.8.22.8.2
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
dart_style-1.3.62.2.0
file-5.2.16.1.2
html-0.14.0+40.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
logging-1.0.21.0.2
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
pedantic-1.11.11.11.1
pointycastle-3.0.13.4.0
rxdart-0.27.30.27.3
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.39.17` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.3.0` on analyzer_plugin does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions analyzer_plugin to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

1
likes
50
pub points
0%
popularity

auto generate R file; like android R file;

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

analyzer, analyzer_plugin, basic_utils, glob, json2yaml, path, pub_semver, quick_log, yaml

More

Packages that depend on r_assets