quiver 3.2.1 icon indicating copy to clipboard operation
quiver: ^3.2.1 copied to clipboard

Quiver is a set of utility libraries for Dart that makes using many Dart libraries easier and more convenient, or adds additional functionality.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add quiver

With Flutter:

 $ flutter pub add quiver

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  quiver: ^3.2.1

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:quiver/async.dart';
import 'package:quiver/cache.dart';
import 'package:quiver/check.dart';
import 'package:quiver/collection.dart';
import 'package:quiver/core.dart';
import 'package:quiver/iterables.dart';
import 'package:quiver/pattern.dart';
import 'package:quiver/strings.dart';
import 'package:quiver/testing/async.dart';
import 'package:quiver/testing/equality.dart';
import 'package:quiver/testing/src/async/fake_async.dart';
import 'package:quiver/testing/src/equality/equality.dart';
import 'package:quiver/testing/src/time/time.dart';
import 'package:quiver/testing/time.dart';
import 'package:quiver/time.dart';
430
likes
130
pub points
99%
popularity

Publisher

verified publisher icongoogle.dev

Quiver is a set of utility libraries for Dart that makes using many Dart libraries easier and more convenient, or adds additional functionality.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

matcher

More

Packages that depend on quiver