qs 0.0.1-nullsafety.3
qs: ^0.0.1-nullsafety.3 copied to clipboard

A query string encoding and encoding library. It's better to use with protobuf(go), gorilla/schema(go) and qs(js).

0
likes
50 / 130
pub points
18 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:10:8

   ╷
10 │   sdk: '>=2.10.0-0 <2.11.0'
   │        ^^^^^^^^^^^^^^^^^^^^
   ╵

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...
stderr: FINE: Pub 2.13.4
SLVR: fact: qs is 0.0.1-nullsafety.3
SLVR: derived: qs
SLVR: fact: qs requires SDK version >=2.10.0-0 <2.11.0
SLVR: conflict: qs requires SDK version >=2.10.0-0 <2.11.0
SLVR: Version solving took 0:00:00.039789 seconds.
    | Tried 1 solutions.
FINE: Resolving dependencies finished (0.053s).
ERR : The current Dart SDK version is 2.13.4.
    | 
    | Because qs requires SDK version >=2.10.0-0 <2.11.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 308:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 129:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 93:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 113:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 126:11                              captureErrors
[...]
    | 
    | Because qs requires SDK version >=2.10.0-0 <2.11.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 308:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 129:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 93:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 113:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 126:11                              captureErrors
    | package:pub/src/command.dart 164:13                            PubCommand.run
    | package:args/command_runner.dart 196:27                        CommandRunner.runCommand
    | package:dartdev/dartdev.dart 199:30                            DartdevRunner.runCommand
    | package:args/command_runner.dart 112:25                        CommandRunner.run.<fn>
    | dart:async                                                     new Future.sync
    | package:args/command_runner.dart 112:14                        CommandRunner.run
    | package:dartdev/dartdev.dart 53:29                             runDartdev
    | /b/s/w/ir/cache/builder/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
---- End log transcript ----
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.13.4. Cannot run `dart pub outdated`.

pubspec.yaml:10:8

   ╷
10 │   sdk: '>=2.10.0-0 <2.11.0'
   │        ^^^^^^^^^^^^^^^^^^^^
   ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.13.4.

pubspec.yaml:10:8

   ╷
10 │   sdk: '>=2.10.0-0 <2.11.0'
   │        ^^^^^^^^^^^^^^^^^^^^
   ╵

Try widening the upper boundary of the constraint.

Support sound null safety
0 / 20

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.19.0, Dart 2.13.4.

0
likes
50
pub points
18%
popularity

Publisher

ronbb.fun

A query string encoding and encoding library. It's better to use with protobuf(go), gorilla/schema(go) and qs(js).

Repository (GitHub)
View/report issues

License

BSD (LICENSE)

More

Packages that depend on qs