qonto 0.1.0 icon indicating copy to clipboard operation
qonto: ^0.1.0 copied to clipboard

Qonto REST API implementation on Dart, based on Qonto REST API v2.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 10 API elements (60.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: Name source files using lowercase_with_underscores.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/Attachment.dart

INFO: Name source files using lowercase_with_underscores.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/BankAccount.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.10.12.20.13.5
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.17.01.17.0
http_parser-3.1.44.0.2
path-1.8.21.8.2
pedantic-1.11.11.11.1
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.12.1 on http does not support the stable version 0.13.0.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

0
likes
100
pub points
0%
popularity

Publisher

verified publisher iconmakepad.fr

Qonto REST API implementation on Dart, based on Qonto REST API v2.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

http

More

Packages that depend on qonto