pushpole 1.7.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

PushPole flutter #

A plugin to use PushPole sdk in Flutter framework.

Run the sample #

Run: git clone https://github.com/push-pole/flutter-sample.git
The go to example: cd example
And run the example on a connected device: flutter run

Installation #

Add the plugin to pubspec.yaml:

dependencies:
  pushpole: ^version

Then run flutter packages get to sync the libraries.

Set up credentials #

Go to https://console.push-pole.com , create an application with the same package name and get the manifest tag. Add the manifest tag in the Application tag. It should be something like this:

<meta-data android:name="com.pushpole.sdk.token"
           android:value="PUSHPOLE_12345678" />

Add the code snippets #

In your main.dart:

import 'package:pushpole/pushpole.dart';
PushPole.initialize();

More Info #

For more details, visit HomePage docs

1.7.1 #

  • Update native android module to latest.

  • Fix problem with FirebaseMessaging 20.1.0

1.7.0 #

  • Update native android module to latest

1.0.2 #

  • Minor bug fixes

1.0.1 #

  • Fix problem with AndroidX projects.

  • Changed example package name.

1.0.0 #

  • Release ready version.

  • New listener API for notification callbacks.

  • Removed extra files and APIs.

  • Remove extra Fcm service. Firebase and other services can now be added and supported natively.

  • Minor improvements and bug fixes.

Note: Callbacks will be passed when flutter is running. So when the app is closed, notifications will not call the callback methods (They actually will, but the flutter doesn't get it).

example/lib/main.dart

import 'pushpole_sample.dart';
import 'package:flutter/material.dart';

void main() => runApp(PushPoleSampleApp());

class PushPoleSampleApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'PushPole sample',
      theme: ThemeData(
        primarySwatch: Colors.blueGrey,
      ),
      home: PushPoleSampleWidget()
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pushpole: ^1.7.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pushpole/pushpole.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform Linux

Because:

  • package:pushpole/pushpole.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Web

Because:

  • package:pushpole/pushpole.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Windows

Because:

  • package:pushpole/pushpole.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform macOS

Because:

  • package:pushpole/pushpole.dart that declares support for platforms: Android, iOS

Package not compatible with SDK dart

Because:

  • pushpole that is a package requiring null.

Health suggestions

Fix lib/pushpole.dart. (-1 points)

Analysis of lib/pushpole.dart reported 2 hints:

line 133 col 20: The declaration '_' isn't referenced.

line 188 col 26: The declaration '_' isn't referenced.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test