pusher_beams_server 0.1.4
pusher_beams_server: ^0.1.4 copied to clipboard

A Pusher Beams Client for sending push notifications to users.

3
likes
90/ 130
pub points
26%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 7 API elements (85.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/pusher_beams_server.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+20.12.20.13.3
jaguar_jwt^2.1.62.1.63.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
auth_header-2.1.43.0.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
http_parser-3.1.44.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^2.1.6` on jaguar_jwt does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions jaguar_jwt to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Dart 2.14.0.

3
likes
90
pub points
26%
popularity

Publisher

suragch.dev

A Pusher Beams Client for sending push notifications to users.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, jaguar_jwt

More

Packages that depend on pusher_beams_server