pubversion 1.0.1

  • Readme
  • Changelog
  • Installing
  • 48

Pub Package Build Status Dart Version GitHub issues CodeFactor

A command-line tool for easily incrementing pubspec.yaml version numbers.

Installation #

pubversion is not meant to be used as a dependency. Instead, it should be "activated".

$ pub global activate pubversion
# or
$ flutter pub global activate pubversion

Learn more about activating and using packages here.

Usage #

pubversion provides three commands:

  • major
  • minor
  • patch

pubversion major #

$ pubversion major
test_package upgraded from 1.2.1 to 2.0.0

pubversion minor #

$ pubversion minor
test_package upgraded from 1.0.1 to 1.1.0

pubversion patch #

$ pubversion patch
test_package upgraded from 1.0.0 to 1.0.1

1.0.1 #

  • Housekeeping for Dart SDK 2.7.0

1.0.0 #

  • Initial release with all features working.

1.0.0-rc.2 #

  • Spelling corrections.
  • Set up Travis CI.

1.0.0-rc.1 #

  • Initial working version.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate pubversion

2. Use it

The package has the following executables:


$ pubversion
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Binary only

Cannot assign flutter SDK tag because it is binary only

Binary only

Cannot assign flutter platform tags, it is a binary only package

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting pubversion... Initialized dartdoc with 37 libraries in 34.4 seconds Validating docs... no issues found Documented 0 public libraries in 7.0 seconds stderr: Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:218:9)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
args ^1.5.2 1.6.0
io ^0.3.3 0.3.4
path ^1.6.4 1.7.0
pub_semver ^1.4.2 1.4.4
pubspec_parse ^0.1.5 0.1.5
Transitive dependencies
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.13
json_annotation 3.0.1
meta 1.2.1
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
yaml 2.2.1
Dev dependencies
pedantic ^1.9.0