pub_semver 2.0.0
pub_semver: ^2.0.0 copied to clipboard

Versions and version constraints implementing pub's versioning policy. This is very similar to vanilla semver, with a few corner cases.

42
likes
130 / 130
pub points
99 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 77 out of 82 API elements (93.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Dart 2.13.4.

42
likes
130
pub points
99%
popularity

Publisher

tools.dart.dev

Versions and version constraints implementing pub's versioning policy. This is very similar to vanilla semver, with a few corner cases.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

collection

More

Packages that depend on pub_semver