pub_mirror 1.0.7
pub_mirror: ^1.0.7 copied to clipboard

Dart native

A multi-thread tool to download content from Pub. Then the result can be served by a http server and taken as the backend of pub, flutter or even Pub Mirror itself.

0
likes
75 / 110
pub points
34 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:4:49

  ╷
4 │ <p>A multi-thread tool to download content from <a href="http://pub.dartlang.org">Pub</a>.
  │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/pub_mirror.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 40 API elements (22.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pub_mirror/pub_mirror.dart that imports:
  • package:pub_mirror/json.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/http.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.11.6.02.0.0
executor^2.1.22.2.22.2.2
http^0.11.3+170.11.3+170.13.0
logging^0.11.3+20.11.41.0.0
path^1.6.21.8.01.8.0
pedantic^1.4.01.11.01.11.0
pub_client^3.0.33.0.33.0.3
quiver^2.1.2+12.1.53.0.0
quiver_log^1.0.61.0.61.0.6
retry^3.0.0+13.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
json_annotation-2.4.04.0.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.5.1` on args does not support the stable version `2.0.0`, that was published 26 days ago.

When args is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.11.3+17` on http does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Dart 2.12.0.

0
likes
75
pub points
34%
popularity

A multi-thread tool to download content from Pub. Then the result can be served by a http server and taken as the backend of pub, flutter or even Pub Mirror itself.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

i@huiyiqun.me

License

BSD (LICENSE)

Dependencies

args, executor, http, logging, path, pedantic, pub_client, quiver, quiver_log, retry

More

Packages that depend on pub_mirror